<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=iso-8859-1">
<META content="MSHTML 6.00.2800.1515" name=GENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=#ffffff>
<DIV><FONT face=Arial size=2>Hello,</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>I tried a similar command, with GiD 7.5.3b, and the 
included sample problemtype "ansys55_3D" </FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>I creatde some&nbsp;surfaces, loaded the 
problemtype, and used</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>set values "1 0 1 0 1 0"<BR>set ligne "1 
3"<BR>GiD_AssignData condition&nbsp; Surface-Constraints surfaces $values $ligne 
<BR></DIV></FONT>
<DIV><FONT face=Arial size=2>And it assigned well this condition values to the 
surfaces 1 and 3</FONT></DIV>
<DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>Check the value of your parameters $values and 
$ligne.</FONT></DIV>
<DIV><FONT face=Arial size=2><FONT size=3><FONT face="Times New Roman"><FONT 
color=#ff0000><FONT color=#ff0000>GiD_AssignData condition Selection_of_Surfaces 
surfaces $values $ligne</FONT><FONT color=#000000> 
</FONT></FONT></FONT></FONT></FONT></DIV><FONT face=Arial size=2><FONT 
size=3><FONT face="Times New Roman"><FONT color=#ff0000><STRONG></STRONG>
<DIV><FONT face=Arial color=#000000 size=2>- values must have the same number of 
parameters as&nbsp;in the&nbsp;'Selection_of_Surfaces' condition definition ( 
see .cnd file)</FONT></DIV>
<DIV><FONT face=Arial color=#000000 size=2>- ligne must have a list of surface 
identifiers</FONT></DIV>
<DIV><FONT face=Arial color=#000000 size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial color=#000000 size=2>Can use WarnWinText to debug your 
current values</FONT></DIV>
<DIV><FONT face=Arial color=#000000 size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial size=2>WarnWinText "values=$values 
ligne=$ligne"</FONT></DIV>
<DIV><FONT color=#0000ff>GiD_AssignData condition Selection_of_Surfaces surfaces 
$values $ligne </FONT></DIV>
<DIV><FONT face=Arial color=#000000 size=2></FONT><FONT face=Arial color=#000000 
size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial color=#000000 size=2></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial color=#000000 size=2>Enrique Escolano</FONT></DIV>
<DIV><BR></FONT></FONT></FONT></FONT>----- Original Message ----- </DIV>
<BLOCKQUOTE dir=ltr 
style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
  <DIV 
  style="BACKGROUND: #e4e4e4; FONT: 10pt arial; font-color: black"><B>From:</B> 
  <A title=ieea@club-internet.fr href="mailto:ieea@club-internet.fr">IEEA</A> 
  </DIV>
  <DIV style="FONT: 10pt arial"><B>To:</B> <A title=gidlist@gatxan.cimne.upc.es 
  href="mailto:gidlist@gatxan.cimne.upc.es">GIDliste</A> </DIV>
  <DIV style="FONT: 10pt arial"><B>Sent:</B> Friday, August 12, 2005 3:30 
  PM</DIV>
  <DIV style="FONT: 10pt arial"><B>Subject:</B> [GiDlist] GiD_AssignData : bug 
  with surfaces !?</DIV>
  <DIV><BR></DIV>Hello, 
  <P>I encounter some problems each time I automatically assign a condition to 
  some surfaces in GID 7.5.3b. 
  <P>The command I used is : 
  <P><B>...</B> <BR><B>#-- Lecture du mot cle #SELECTEDSURFACES 
  --------------------------------------</B> <BR><B>&nbsp;if {[string equal 
  "#SELECTEDSURFACES" $chaine] == 1} then {</B> <BR><B>&nbsp; incr position</B> 
  <BR><B>&nbsp; set ligne&nbsp;&nbsp; [lindex $list_ligne $position]</B> 
  <BR><B>&nbsp; set list&nbsp;&nbsp; [split $ligne]</B> <BR><B>&nbsp; set 
  nb_element_list&nbsp; [llength $list]</B> <BR><B>&nbsp; set 
  nbslctd_surfaces&nbsp;&nbsp; [lindex $list 0]</B> <BR><B>&nbsp; incr 
  position</B> <BR><B>&nbsp; set ligne&nbsp;&nbsp; [lindex $list_ligne 
  $position]</B> <BR><B>&nbsp; set liste&nbsp;&nbsp; [split $ligne]</B> 
  <BR><B>&nbsp; set laliste&nbsp;&nbsp; [list $liste]</B> <BR><B>&nbsp; set 
  nb_element_list&nbsp; [llength $liste]</B> <BR><B>&nbsp; set values&nbsp; 
  ""</B> <BR><B>&nbsp; <FONT color=#ff0000>GiD_AssignData condition 
  Selection_of_Surfaces surfaces $values $ligne</FONT></B> <BR><B>&nbsp;}</B> 
  <BR><B>...</B> 
  <P>where Selection_of_Surfaces is the name of my condition and ligne is a list 
  deduced from the reading of a file. 
  <P>I do the same for lines and points (using the same type of procedure) and I 
  have no problem. 
  <P>Do you think that I made a mistake or there is a bug in GID 7.5.3b ? Is 
  there the same problem with the newest version of GID ? 
  <P>Thank you. 
  <P>G.W.R. Geis <BR>&nbsp; <BR>&nbsp; </P></BLOCKQUOTE></BODY></HTML>